conf t

インフラエンジニアのメモ

loopbackによるBGPネイバー接続

 

loopbackインタフェースはダウンしないため、

loopbackインタフェースに対してルーティングを設定する

ことは効果的です。

 

経路を冗長化する場合も、ループバックインタフェースを

指定してルーティングします。

 

以下今回作成するネットワークです。

f:id:monaski:20140112113530p:plain

 

設定します。

今回の設定では、対抗ルータの物理インタフェースまでで1ホップ、

そこからループバックインタフェースまでに2ホップかかります。

しかし、EBGPのネイバーはホップ数1までしか許しません。

そのためneighbor 200.1.1.1 ebgp-multihop 2でホップ数2まで許可します。

 

また、経路のロードバランスをするためmaximum-paths 2を用います。

 

R1R2

R1(config)#int lo 0

R1(config-if)#ip add

*Mar  1 00:02:29.775: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up

R1(config-if)#ip add 100.1.1.1 255.255.255.255

 

 


R1(config)#router bgp 100
R1(config-router)#neighbor 200.1.1.1 remote-as 200
R1(config-router)#neighbor 200.1.1.1 update-source loopback 0
R1(config-router)#neighbor 200.1.1.1 ebgp-multihop 2
R1(config-router)#maximum-paths 2

R1(config)#ip route 200.1.1.1 255.255.255.255 200.0.0.2
R1(config)#ip route 200.1.1.1 255.255.255.255 200.0.0.6

R2(config-if)#int lo 0
R2(config-if)#ip add
*Mar 1 00:02:55.883: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up
R2(config-if)#ip add 200.1.1.1 255.255.255.255
R2(config-if)#no shut
R2(config-if)#exit
R2(config)#router bgp 200
R2(config-router)#neighbor 100.1.1.1 remote-as 100
R2(config-router)#neighbor 100.1.1.1 update-source lo 0
R2(config-router)#neighbor 100.1.1.1 ebgp-multihop 2
R2(config-router)#maximum-paths 2
R2(config-router)#exit
R2(config)#ip route 100.1.1.1 255.255.255.255 200.0.0.1
R2(config)#ip route 100.1.1.1 255.255.255.255 200.0.0.5
R2(config)#
*Mar 1 00:05:53.787: %BGP-5-ADJCHANGE: neighbor 100.1.1.1 Up
R2(config)#

 

 上記ではloopbackインタフェースにno shutdownコマンドを入れていますが、本当は必要ありません。

loopbackインタフェースは作成した時点でUPするようです。

 

さっそくshow ip routeを確認してみるも、あれ?BGPの経路がない?

 

それもそのはず。前述の設定はあくまでBGPネイバーを設定しただけ。

BGPで何を伝えるかを設定していませんでした。

ということで、ネットワークを以下のように拡張し、それを対向の

BGPルータに伝えることにします。

f:id:monaski:20140112140337p:plain

前回と同じようにnetworkコマンドで指定するのもつまらないので

IGPからBGPへの再配送を使います。方法はIGP同士で再配送するのと同じです。

 

R1R2
R1(config)#router bgp 100
R1(config-router)#redistribute eigrp 1
R2(config)#router bgp 200
R2(config-router)#redistribute ospf 1

 ※各ルータへのIGPの設定とインタフェースへのIP割り当ては省略

設定は以上です。

 

show ip routeすると、BGPのルートが配送されていました。

f:id:monaski:20140112142654p:plain

100.1.1.1、200.1.1.1への経路も それぞれ2つ乗っていることを確認できました。

冗長化ができています。